EIGRP Support for Route Map Filtering
The EIGRP Support for Route Map Filtering feature enables Enhanced Interior Gateway Routing Protocol (EIGRP) to interoperate with other protocols by filtering inbound and outbound traffic based on complex route map options. In addition to the existing route map facility, several extended filtering options are introduced to provide EIGRP-specific match choices.
Your Cisco IOS software release may not support all of the features documented in this module. To reach links to specific feature documentation in this module and to see a list of the releases in which each feature is supported, use the "Feature Information for EIGRP Support for Route Map Filtering" section.
Use Cisco Feature Navigator to find information about platform support and Cisco IOS and Catalyst OS software image support. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.
Contents
Information About EIGRP Support for Route Map Filtering
EIGRP Route Map Support
EIGRP support for route map filtering enables EIGRP to interoperate with other protocols by filtering inbound and outbound traffic based on route map options. Additional EIGRP-specific match choices are introduced to allow flexibility in fine-tuning EIGRP network operations.
EIGRP now supports the route map filtering capability that exists for other routing protocols to filter routes being redistributed into their protocol. For more details about understanding and configuring route maps, see the Enabling Policy Routing section of the "Configuring IP Routing Protocol-Independent Features" chapter of the Cisco IOS IP Routing Protocols Configuration Guide, Release 12.4T.
New match options allow EIGRP to filter internal and external routes based on source protocols, to match a metric against a range, and to match on an external protocol metric.
EIGRP can be configured to filter traffic using a route map and the redistribute or distribute-list commands. Using a route map with the redistribute command allows routes that are redistributed from the routing table to be filtered with a route map before being admitted into an EIGRP topology table. Routes that are dynamically received from, or advertised to, EIGRP peers can be filtered by adding a route map option to the distribute-list command.
A route map may be configured with both the redistribute and the distribute-list commands in the same routing process. When a route map is used with a distribute-list command that is configured for inbound or outbound filtering, route packets that are learned from or advertised to EIGRP peers can be processed with the route map to provide better control of route selection during the route exchange process. Redistribution serves as a mechanism to import routes into the EIGRP topology table from a routing table. A route map configured with the redistribute command adds flexibility to the redistribution capability and results in a more specific redistributed route selection.
In summary, demands for EIGRP to interoperate with other protocols and flexibility in fine-tuning network operation necessitate the capability to filter traffic using a route map.
How to Configure EIGRP Support for Route Map Filtering
•Configuring EIGRP Metrics Using a Route Map (required)
•Verifying EIGRP Metrics (optional)
Configuring EIGRP Metrics Using a Route Map
Perform this task configure EIGRP metrics using a route map. In the Detailed Steps below, the EIGRP metrics used for filtering are configured within a route map. The first match clause defines EIGRP routes that contain an external protocol metric between 400 and 600 inclusive;the second match clause defines EIGRP external routes that match a source protocol of BGP and the autonomous system 45000. When the two match clauses are true, a tag value of the destination routing protocol is set to 5. This route map can be used with the distribute-list command, see the "Configuring EIGRP Metrics Using a Route Map: Examples" section for an example configuration.
SUMMARY STEPS
DETAILED STEPS
Verifying EIGRP Metrics
To verify that both the EIGRP metric and the external protocol metrics have been configured, perform the following step.
SUMMARY STEPS
2. show ip eigrp topology [autonomous-system-number | ip-address [mask]] [active | all-links | detail-links | pending | summary | zero-successors]
DETAILED STEPS
Router# enable
Step 2 show ip eigrp topology [autonomous-system-number | ip-address [mask]] [active | all-links | detail-links | pending | summary | zero-successors]
Router# show ip eigrp topology 172.16.1.0/24
IP-EIGRP (AS 45000): Topology entry for 172.16.1.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856
Routing Descriptor Blocks:
0.0.0.0 (Serial4/0), from Connected, Send flag is 0x0
Composite metric is (2169856/0), Route is Internal
Vector metric:
Minimum bandwidth is 1544 Kbit
Total delay is 20000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 0
Router# show ip eigrp topology 192.168.1.0/24
IP-EIGRP (AS 45000): Topology entry for 192.168.1.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 2169856
Routing Descriptor Blocks:
0.0.0.0 (Serial4/0), from Connected, Send flag is 0x0
Composite metric is (2169856/0), Route is External
Vector metric:
Minimum bandwidth is 1544 Kbit
Total delay is 20000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 10.89.245.1
AS number of route is 0
External protocol is Connected, external metric is 0
Administrator tag is 0 (0x00000000)
Configuration Examples for EIGRP Support for Route Map Filtering
Configuring EIGRP Metrics Using a Route Map: Examples
The following example shows how to configure a route map to match an EIGRP external protocol metric route with an allowable deviation of 100, a source protocol of BGP, and an autonomous system 45000. When the two match clauses are true, the tag value of the destination routing protocol is set to 5. The route map is used to distribute incoming packets for an EIGRP process.
route-map metric_range
match metric external 500 +- 100
match source-protocol bgp 45000
set tag 5
!
router eigrp 1
network 172.16.0.0
distribute-list route-map metric_range in
The following example shows how to configure a route map to match EIGRP routes with a metric of 110, 200, or an inclusive range of 700 to 800. When the match clause is true, the tag value of the destination routing protocol is set to 10. The route map is used to redistribute EIGRP packets.
route-map metric_eigrp
match metric 110 200 750 +- 50
set tag 10
!
router eigrp 1
network 172.21.1.0/24
redistribute eigrp route-map metric_eigrp
Additional References
The following sections provide references related to the EIGRP Support for Route Map Filtering feature.
Related Documents
Cisco IOS IP Configuration Guide, Part 2: IP Routing Protocols, Release 12.3 | |
•Cisco IOS IP Command Reference, Volume 2 of 4: Routing Protocols, Release 12.3T •Cisco IOS IP Routing Protocols Command Reference, Release 12.2SR •Cisco IOS IP Routing Protocols Command Reference, Release 12.2SX |
Technical Assistance
The Cisco Support website provides extensive online resources, including documentation and tools for troubleshooting and resolving technical issues with Cisco products and technologies. |
Command Reference
match metric (IP)
To redistribute routes with the specified metric, use the match metric command in route-map configuration mode. To remove the entry for the redistributed route from the routing table, use the no form of this command.
Syntax Description
Command Default
Command Modes
Command History
Usage Guidelines
Use the route-map global configuration command and the match and set route-map configuration commands to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria—the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions—the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.
The match route-map configuration command has multiple formats. The match commands can be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.
A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want to modify only some data, you must configure a second route map section with an explicit match specified.
Note An external protocol route metric is not the same as the EIGRP assigned route metric which is a figure computed using EIGRP vectorized metric components (delay, bandwidth, reliability, load, and MTU).
Examples
route-map name
match metric 5
In the following example, any metric that falls inclusively in the range from 400 to 600 is matched:
route-map name
match metric 500 +- 100
The following example shows how to configure a route map to match an EIGRP external protocol metric route with an allowable deviation of 100, a source protocol of BGP, and an autonomous system 45000. When the two match clauses are true, the tag value of the destination routing protocol is set to 5. The route map is used to distribute incoming packets for an EIGRP process.
route-map metric_range
match metric external 500 +- 100
match source-protocol bgp 45000
set tag 5
!
router eigrp 45000
network 172.16.0.0
distribute-list route-map metric_range in
Related Commands
match source-protocol
To match Enhanced Interior Gateway Routing Protocol (EIGRP) external routes based on a source protocol and autonomous system number, use the match source-protocol command in route-map configuration mode. To remove the protocol to be matched, use the no form of this command.
Syntax Description
Command Default
Command Modes
Command History
Usage Guidelines
This command may not be useful with a redistribution operation that employs route maps because redistribution usually requires the configuration of a source protocol and an autonomous system value in order to redistribute. In many cases, it is more useful to configure a route map that includes matching the route type based on the source protocol and autonomous system using the distribute-list command for EIGRP.
Examples
The following example shows how to configure a route map to match a source protocol of BGP and an autonomous system 45000. When the match clause is true, the tag value of the destination routing protocol is set to 5. The route map is used to distribute incoming packets for an EIGRP process.
route-map metric_source
match source-protocol bgp 45000
set tag 5
!
router eigrp 45000
network 172.16.0.0
distribute-list route-map metric_source in
Related Commands
show ip eigrp topology
To display entries in the Enhanced Interior Gateway Routing Protocol (EIGRP) topology table, use the show ip eigrp topology command in privileged EXEC mode.
show ip eigrp topology [autonomous-system-number | ip-address [mask] | name [interfaces]] [active | all-links | pending | summary | zero-successors]
Syntax Description
Command Default
If this command is used without any keywords or arguments, then only routes that are feasible successors are displayed.
Command Modes
Command History
Usage Guidelines
The show ip eigrp topology command can be used without any keywords or arguments. If this command is used without any keywords or arguments, then only routes that are feasible successors are displayed. The show ip eigrp topology command can be used to determine Diffusing Update Algorithm (DUAL) states and to debug possible DUAL problems. The show ip eigrp topology name command option indicates that the output displayed will be for a named service topology for MTR.
Examples
Router# show ip eigrp topology
IP-EIGRP Topology Table for process 77
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
r - Reply status
P 10.16.90.0 255.255.255.0, 2 successors, FD is 0
via 10.16.80.28 (46251776/46226176), Ethernet0
via 10.16.81.28 (46251776/46226176), Ethernet1
via 10.16.80.31 (46277376/46251776), Serial0
P 10.16.81.0 255.255.255.0, 1 successors, FD is 307200
via Connected, Ethernet1
via 10.16.81.28 (307200/281600), Ethernet1
via 10.16.80.28 (307200/281600), Ethernet0
via 10.16.80.31 (332800/307200), Serial0
Router# show ip eigrp topology 10.2.1.0/24
IP-EIGRP (AS 1): Topology entry for 10.2.1.0/24
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 281600 Routing Descriptor
Blocks:
0.0.0.0 (Ethernet0/0), from Connected, Send flag is 0x0 Composite metric is (281600/0),
Route is Internal !This is the internal route.
Vector metric: Minimum bandwidth is 10000 Kbit
Total delay is 1000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 0
Router# show ip eigrp topology 10.4.80.0/20
IP-EIGRP (AS 1): Topology entry for 10.4.80.0/20
State is Passive, Query origin flag is 1, 1 Successor(s), FD is 409600
Routing Descriptor Blocks:
10.2.1.1 (Ethernet0/0), from 10.2.1.1, Send flag is 0x0
Composite metric is (409600/128256), Route is External !This is the external route.
Vector metric:
Minimum bandwidth is 10000 Kbit
Total delay is 6000 microseconds
Reliability is 255/255
Load is 1/255
Minimum MTU is 1500
Hop count is 1
External data:
Originating router is 10.89.245.1
AS number of route is 0
External protocol is Connected, external metric is 0
Administrator tag is 0 (0x00000000)
Table 1 describes the significant fields shown in the displays.
Feature Information for EIGRP Support for Route Map Filtering
Table 2 lists the release history for this feature.
Not all commands may be available in your Cisco IOS software release. For release information about a specific command, see the command reference documentation.
Use Cisco Feature Navigator to find information about platform support and software image support. Cisco Feature Navigator enables you to determine which Cisco IOS and Catalyst OS software images support a specific software release, feature set, or platform. To access Cisco Feature Navigator, go to http://www.cisco.com/go/cfn. An account on Cisco.com is not required.
Note Table 2 lists only the Cisco IOS software release that introduced support for a given feature in a given Cisco IOS software release train. Unless noted otherwise, subsequent releases of that Cisco IOS software release train also support that feature.
No comments:
Post a Comment