Jan 11, 2011

OSPF distribute-list example (Block Lists)

lated routers under Dynamips / Dynagen / GNS3. Network diagram was exported from the running GNS3 model.
Distribute List EIGRP vs OSPF.png

[edit] Base device configurations

[edit] R0 (172.16.0.1)

version 12.4
!
hostname R0
!
ip cef
no ip domain lookup
!
interface Loopback0
ip address 172.16.0.1 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.0.1 255.255.255.252
duplex auto
speed auto
!
end

[edit] R1 (172.16.0.2)

version 12.4
!
hostname R2
!
ip cef
no ip domain lookup
!
interface Loopback0
ip address 172.16.0.2 255.255.255.255
!
interface FastEthernet0/0
ip address 10.1.0.2 255.255.255.252
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 10.2.0.1 255.255.255.252
duplex auto
speed auto
!
 
end

[edit] R3 (172.16.0.3)

version 12.4
!
hostname R3
!
ip cef
no ip domain lookup
!
interface Loopback0
ip address 172.16.0.3 255.255.255.255
!
interface Loopback1
  ip address 192.168.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 10.2.0.2 255.255.255.252
duplex auto
speed auto
!
end

[edit] OSPF distribute-list example (Block Lists)

[edit] Base OSPF Configuration, without block lists

[edit] R0 (172.16.0.1)

router ospf 1
router-id 172.16.0.1
log-adjacency-changes
network 10.1.0.0 0.0.0.3 area 0
network 172.16.0.1 0.0.0.0 area 0
!

[edit] R1 (172.16.0.2)

router ospf 1
router-id 172.16.0.2
log-adjacency-changes
network 10.1.0.0 0.0.0.3 area 0
network 10.2.0.0 0.0.0.3 area 0
network 172.16.0.2 0.0.0.0 area 0
!

[edit] R2 (172.16.0.3)

router ospf 1
router-id 172.16.0.3
redistribute connected subnets metric-type 1
log-adjacency-changes
network 10.2.0.0 0.0.0.3 area 0
network 172.16.0.3 0.0.0.0 area 0
!
Router R2 is redistributing the loopback adapter 192.168.1.0 into OSPF in order to generate an LSA Type 5 (area-filters must be used for LSA type 3s). The route makes it from router R2, to R1, to R0. See the routing output below, important information highlighted.

[edit] OSPF Standard routing - no distribute-list

[edit] R0 show ip route example – OSPF Standard routing

R0#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/32 is subnetted, 3 subnets
C       172.16.0.1 is directly connected, Loopback0
O       172.16.0.2 [110/2] via 10.1.0.2, 00:00:00, FastEthernet0/0
O       172.16.0.3 [110/3] via 10.1.0.2, 00:00:00, FastEthernet0/0
     10.0.0.0/30 is subnetted, 2 subnets
O       10.2.0.0 [110/2] via 10.1.0.2, 00:00:00, FastEthernet0/0
C       10.1.0.0 is directly connected, FastEthernet0/0
     192.168.1.0/32 is subnetted, 1 subnets
O       192.168.1.1 [110/3] via 10.1.0.2, 00:00:00, FastEthernet0/0

[edit] R0 show ospf database – OSPF Standard routing

R0#sh ip ospf database
            OSPF Router with ID (172.16.0.1) (Process ID 1)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
172.16.0.1      172.16.0.1      1284        0x80000004 0x008449 2
172.16.0.2      172.16.0.2      1346        0x80000002 0x00A4FB 3
172.16.0.3      172.16.0.3      419         0x80000006 0x00D6E8 2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
10.1.0.1        172.16.0.1      1350        0x80000001 0x00E70F
10.2.0.2        172.16.0.3      1347        0x80000001 0x00D917
 
                Type-5 AS External Link States
 
Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.1.0     172.16.0.3      411         0x80000001 0x00F009 0

[edit] R1 show ip route example – OSPF Standard Config

R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/32 is subnetted, 3 subnets
O       172.16.0.1 [110/2] via 10.1.0.1, 00:01:32, FastEthernet0/0
C       172.16.0.2 is directly connected, Loopback1
O       172.16.0.3 [110/2] via 10.2.0.2, 00:01:32, FastEthernet1/0
     10.0.0.0/30 is subnetted, 2 subnets
C       10.2.0.0 is directly connected, FastEthernet1/0
C       10.1.0.0 is directly connected, FastEthernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
O E1    192.168.1.0 [110/21] via 10.2.0.2, 00:01:32, FastEthernet1/0

[edit] R1 show ip ospf database example – OSPF Standard Config

R1# sh ip ospf database
 
            OSPF Router with ID (172.16.0.2) (Process ID 1)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
172.16.0.1      172.16.0.1      984         0x80000004 0x008449 2
172.16.0.2      172.16.0.2      1044        0x80000002 0x00A4FB 3
172.16.0.3      172.16.0.3      117         0x80000006 0x00D6E8 2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
10.1.0.1        172.16.0.1      1050        0x80000001 0x00E70F
10.2.0.2        172.16.0.3      1045        0x80000001 0x00D917
 
                Type-5 AS External Link States
 
Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.1.0     172.16.0.3      109         0x80000001 0x00F009 0
 
We can see in the above examples, R2 generates a route and it propagates to R1. All routers along the path have this entry in their OSPF Configuration.

[edit] Adding the Distribute-list (Block List) to OSPF

In OSPF, the distribute-command should be defined as only a mechanism as to whether or not the specific router the distribute-list is configured on accepts a route for insertion into it’s own OSPF table. One of the key points to remember about OSPF is that it’s about global database consistency. Every device must have the same view of the entire topology of the network. Every router knows how to get everywhere else. This functionality is different than EIGRP, as it will be shown below. The distribute-list command on OSPF only tells OSPF which routes it can put in the FIB.

[edit] R1 configuration

router ospf 1
router-id 172.16.0.2
log-adjacency-changes
network 10.1.0.0 0.0.0.3 area 0
network 10.2.0.0 0.0.0.3 area 0
network 172.16.0.2 0.0.0.0 area 0
distribute-list 50 in FastEthernet1/0
!
access-list 50 deny   192.168.1.0 0.0.0.255
access-list 50 permit any
!
The only difference here is that an access-list is applied to the distribute-list statements.

[edit] R1 show ip route example – OSPF Distribute-list applied

We can see in the output below that R1 does not actually have 192.168.1.0/24 in it’s IP routing table. The distribute-list command on R1 blocks this route.
R1#    sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/32 is subnetted, 3 subnets
O       172.16.0.1 [110/2] via 10.1.0.1, 00:00:16, FastEthernet0/0
C       172.16.0.2 is directly connected, Loopback1
O       172.16.0.3 [110/2] via 10.2.0.2, 00:00:16, FastEthernet1/0
     10.0.0.0/30 is subnetted, 2 subnets
C       10.2.0.0 is directly connected, FastEthernet1/0
C       10.1.0.0 is directly connected, FastEthernet0/0
*******192.168.1.0/24 is MISSING*****

[edit] R1 show ip ospf database example – OSPF Distribute-list applied

The distribute-list command only removes the route from the OSPF Table – it does not stop that route from being advertised out to other OSPF Neighbors. This is for database consistencies sake.
R1#sh ip ospf database
 
            OSPF Router with ID (172.16.0.2) (Process ID 1)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
172.16.0.1      172.16.0.1      1164        0x80000004 0x008449 2
172.16.0.2      172.16.0.2      1224        0x80000002 0x00A4FB 3
172.16.0.3      172.16.0.3      297         0x80000006 0x00D6E8 2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
10.1.0.1        172.16.0.1      1230        0x80000001 0x00E70F
10.2.0.2        172.16.0.3      1225        0x80000001 0x00D917
 
                Type-5 AS External Link States
 
Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.1.0     172.16.0.3      289         0x80000001 0x00F009 0

[edit] R1 debug ip ospf spf/tree

Debugging OSPF spf and tree events shows below that LSAs are still generated for 192.168.1.0/24 even though a distribute-list is applied, and that route is still added to the database. Router R1 specifically just chooses not to route for it.
*Mar  1 02:54:36.799: OSPF: Started Building Type 5 External Routes
*Mar  1 02:54:36.803: OSPF: Start processing Type 5 External LSA 192.168.1.0, mask 255.255.255.252, adv 172.16.0.3, age 1905, seq 0x80000001, metric 20, metric-type 1
*Mar  1 02:54:36.803:    Add better path to LSA ID 192.168.1.0, gateway 10.2.0.2, dist 21
*Mar  1 02:54:36.803:    Add path: next-
R1#hop 10.2.0.2, interface FastEthernet1/0
*Mar  1 02:54:36.803:  network update dest_addr 192.168.1.0 mask 255.255.255.252 gateway 10.2.0.2
*Mar  1 02:54:36.807: OSPF: insert route list LS ID 192.168.1.0, type 5, adv rtr 172.16.0.3

[edit] R0 show ip route example – OSPF distribute-list applied

We can see here below that 192.168.1.0 is added to the routing table, with the next-hop IP of R1. You may expect that this route to not enter the OSPF Table, but remember, distribute-list only changes the FIB (forwarding information base) table on the local router it is configured on.
R0#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/32 is subnetted, 3 subnets
C       172.16.0.1 is directly connected, Loopback0
O       172.16.0.2 [110/2] via 10.1.0.2, 00:03:58, FastEthernet0/0
O       172.16.0.3 [110/3] via 10.1.0.2, 00:03:58, FastEthernet0/0
     10.0.0.0/30 is subnetted, 2 subnets
O       10.2.0.0 [110/2] via 10.1.0.2, 00:03:58, FastEthernet0/0
C       10.1.0.0 is directly connected, FastEthernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
O E1    192.168.1.0 [110/22] via 10.1.0.2, 00:03:58, FastEthernet0/0

[edit] R0 – show ip ospf database example – OSPF Distribute-list applied

The output below shows another type-5 LSA from R2 which generates the route. OSPF on R0 will add this LSA to it’s database because it must keep the database consistent.
R0#show ip ospf database
 
            OSPF Router with ID (172.16.0.1) (Process ID 1)
 
                Router Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum Link count
172.16.0.1      172.16.0.1      1135        0x80000004 0x008449 2
172.16.0.2      172.16.0.2      1197        0x80000002 0x00A4FB 3
172.16.0.3      172.16.0.3      270         0x80000006 0x00D6E8 2
 
                Net Link States (Area 0)
 
Link ID         ADV Router      Age         Seq#       Checksum
10.1.0.1        172.16.0.1      1202        0x80000001 0x00E70F
10.2.0.2        172.16.0.3      1198        0x80000001 0x00D917
 
                Type-5 AS External Link States
 
Link ID         ADV Router      Age         Seq#       Checksum Tag
192.168.1.0     172.16.0.3      262         0x80000001 0x00F009 0

[edit] EIGRP distribute-list configuration examples

[edit] Device Configurations

[edit] R0 (172.16.0.1)

router eigrp 1
network 10.1.0.0 0.0.0.3
network 172.16.0.1 0.0.0.0
auto-summary
!

[edit] R1 (172.16.0.2)

router eigrp 1
network 10.1.0.0 0.0.0.3
network 10.2.0.0 0.0.0.3
network 172.16.0.2 0.0.0.0
auto-summary
!

[edit] R2 (172.16.0.3)

router eigrp 1
redistribute connected
network 10.2.0.0 0.0.0.3
network 172.16.0.3 0.0.0.0
auto-summary
!

[edit] EIGRP - Default, standard routing (No distribute-list)

[edit] R1 – show ip route – EIGRP default standard routing

In the below example, we can see that the route from R2 makes it into EIGRP as an EIGRP external route. This is routing as usual and is expected.
R1#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:01:43, Null0
C       172.16.0.2/32 is directly connected, Loopback1
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.2.0.0/30 is directly connected, FastEthernet1/0
D       10.0.0.0/8 is a summary, 00:02:07, Null0
C       10.1.0.0/30 is directly connected, FastEthernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
D EX    192.168.1.0 [170/156160] via 10.2.0.2, 00:01:31, FastEthernet1/0

[edit] R1 – show ip eigrp topology – EIGRP standard routing

This route is added into the EIGRP topology table with the below metrics, as expected.
R1#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.16.0.2)
 
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
 
P 10.2.0.0/30, 1 successors, FD is 28160
        via Connected, FastEthernet1/0
P 10.0.0.0/8, 1 successors, FD is 28160
        via Summary (28160/0), Null0
P 10.1.0.0/30, 1 successors, FD is 28160
       via Connected, FastEthernet0/0
P 192.168.1.0/30, 1 successors, FD is 156160
        via 10.2.0.2 (156160/128256), FastEthernet1/0
P 172.16.0.0/16, 1 successors, FD is 128256
        via Summary (128256/0), Null0
P 172.16.0.2/32, 1 successors, FD is 128256
        via Connected, Loopback1

[edit] R0 - show ip route - EIGRP Standard Routing

The route makes it from R1 to R0, with a next-hop of R1. This is routing as expected.
R0#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:02:28, Null0
C       172.16.0.1/32 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.2.0.0/30 [90/30720] via 10.1.0.2, 00:02:35, FastEthernet0/0
D       10.0.0.0/8 is a summary, 00:02:44, Null0
C       10.1.0.0/30 is directly connected, FastEthernet0/0
     192.168.1.0/30 is subnetted, 1 subnets
D EX    192.168.1.0 [170/158720] via 10.1.0.2, 00:01:53, FastEthernet0/0

[edit] R0 – show ip eigrp topology – EIGRP standard routing

The EIGRP route also makes it into the EIGRP topology of router R0, as expected.
R0#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.16.0.1)
 
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
 
P 10.2.0.0/30, 1 successors, FD is 30720
        via 10.1.0.2 (30720/28160), FastEthernet0/0
P 10.0.0.0/8, 1 successors, FD is 28160
        via Summary (28160/0), Null0
P 10.1.0.0/30, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 192.168.1.0/30, 1 successors, FD is 158720
        via 10.1.0.2 (158720/156160), FastEthernet0/0
P 172.16.0.0/16, 1 successors, FD is 128256
        via Summary (128256/0), Null0
P 172.16.0.1/32, 1 successors, FD is 128256
        via Connected, Loopback0

[edit] EIGRP Distribution list configuration

In the below example, a distribute-list is applied to an interface using EIGRP. In EIGRP, a distribute-list will block route entries from entering the topology table. OSPF and EIGRP maintain their routing tables and make routing decisions differently. OSPF has a single database for the entire network, and each router has the same view of the network. EIGRP maintains a single view for each router. EIGRP operates in a ‘routing by rumor’ method, in which it only learns routes that it’s direct neighbors tell it. This is why it is referred to as a ‘hybrid’ routing protocol, in that it routes by rumors yet still supports link state advertisements and trigged updates.

[edit] R0 Config (172.16.0.3)

router eigrp 1
network 10.1.0.0 0.0.0.3
network 10.2.0.0 0.0.0.3
network 172.16.0.2 0.0.0.0
distribute-list 50 in FastEthernet1/0
auto-summary
!
access-list 50 deny   192.168.1.0 0.0.0.255
access-list 50 permit any
!

[edit] R1 – show ip route – EIGRP Distribute-list applied

R1 does not have 192.168.1.0/24 in it’s routing table anymore since we removed it from the running configuration. We can also see that there’s an EIGRP adjacency change when we apply the configuration, showing that it is truly a routing-by-rumor hybrid protocol and the neighbors topology has changed.
*Mar  1 03:11:13.651: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 1: Neighbor 10.2.0.2 (FastEthernet1/0) is resync: route configuration changed
 
R1#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:07:56, Null0
C       172.16.0.2/32 is directly connected, Loopback1
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C       10.2.0.0/30 is directly connected, FastEthernet1/0
D       10.0.0.0/8 is a summary, 00:08:20, Null0
C       10.1.0.0/30 is directly connected, FastEthernet0/0
**** 192.168.1.0/24 is NOT HERE as per distribute-list ****

[edit] R1 – Show ip eigrp topology – EIGRP distribute-list applied

Unsurprisingly, the distribute-list command has rejected the EIGRP route advertised from R2 and it does not make it into the EIGRP topology table.
R1#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.16.0.2)
 
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
 
P 10.2.0.0/30, 1 successors, FD is 28160
        via Connected, FastEthernet1/0
P 10.0.0.0/8, 1 successors, FD is 28160
        via Summary (28160/0), Null0
P 10.1.0.0/30, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 172.16.0.0/16, 1 successors, FD is 128256
        via Summary (128256/0), Null0
P 172.16.0.2/32, 1 successors, FD is 128256
        via Connected, Loopback1

[edit] R0 – show ip route – EIGRP distribute-list applied

When we get to R0, we can see that 192.168.1.0/24 is also not here --- Since EIGRP routes by rumor and not by a shared topology view, it has no idea that 192.168.1.0/24 is connected to R1, since R1 has rejected the route and topology entry with a distribute-list. This is the biggest difference between OSPF and EIGRP – Distribute-lists on EIGRP do exactly what they are intended to do, while OSPF will not give results.
R0#sh ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route
 
Gateway of last resort is not set
 
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
D       172.16.0.0/16 is a summary, 00:08:23, Null0
C       172.16.0.1/32 is directly connected, Loopback0
     10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
D       10.2.0.0/30 [90/30720] via 10.1.0.2, 00:08:29, FastEthernet0/0
D       10.0.0.0/8 is a summary, 00:08:38, Null0
C       10.1.0.0/30 is directly connected, FastEthernet0/0

[edit] R0 – show ip eigrp topology – EIGRP distribute-list applied

As mentioned prior, EIGRP does not have a topology entry for 192.168.1.0/24 – R0 never hears about the topology entry, since R1 rejects it outright.
R0#sh ip eigrp topology
IP-EIGRP Topology Table for AS(1)/ID(172.16.0.1)
 
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status
 
P 10.2.0.0/30, 1 successors, FD is 30720
        via 10.1.0.2 (30720/28160), FastEthernet0/0
P 10.0.0.0/8, 1 successors, FD is 28160
        via Summary (28160/0), Null0
P 10.1.0.0/30, 1 successors, FD is 28160
        via Connected, FastEthernet0/0
P 172.16.0.0/16, 1 successors, FD is 128256
        via Summary (128256/0), Null0
P 172.16.0.1/32, 1 successors, FD is 128256
        via Connected, Loopback0

[edit] Conclusion

In the examples listed above, we can display the routing protocol differences between EIGRP and OSPF when distribute-lists are used. OSPF distribute lists only change routing decisions on which routes from the OSPF database to add to the RIB and FIB (Forwarding and Routing information bases), or the routing table, on the specific router, but continues to advertise LSAs to other OSPF routers. EIGRP distribute-lists reject the topology and routes advertised from neighbors due to it’s route-by-rumor design, and as such, those routes are not advertised to any other EIGRP neighbors.
References: Cisco IOS 12.4(18), IP Plus on Cisco 3640 series chassis. GNS3, version 0.4 https://gns3.net, based on open-source Dynagen and Dynamips.
i,
Can anyone help me understand prefix lists a little better ?
As can be seen from the output below, I have tried to configure a distribute list within eigrp with the aim of filtering just the route 172.16.1.0/24 .

Using > ip prefix-list test seq 5 deny 172.16.1.0/24
           
            router eigrp 1
network 10.0.24.0 0.0.7.255
network 172.16.0.0
distribute-list prefix test out
no auto-summary

However when I go to R2 the list has filtered all routes 172.16.1.0, 172.16.2.0, 172.16.3.0,172.16.4.0 etc

Is it not possible to filter just one route within a classful network with a prefix list or am I missing something ?

Thanks in advance. Phil.
            
full router config below :

R2#show run
Building configuration...
Current configuration : 1850 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R2
!
boot-start-marker
boot-end-marker
!
enable password cisco
!
no aaa new-model
no network-clock-participate slot 1
no network-clock-participate wic 0
ip cef
!
!
!
!
no ip domain lookup
ip host r1 10.0.24.1
ip host sw1 10.0.24.3
!
multilink bundle-name authenticated
!
!
!
!
!
username phil
archive
log config
  hidekeys
!
!
!
!
!
!
!
interface Loopback1
ip address 172.16.1.2 255.255.255.0
!
interface Loopback2
ip address 172.16.2.2 255.255.255.0
!
interface Loopback3
ip address 172.16.3.2 255.255.255.0
!
interface Loopback4
ip address 172.16.4.2 255.255.255.0
!
interface Loopback5
ip address 172.16.5.2 255.255.255.0
!
interface Loopback6
ip address 172.16.6.2 255.255.255.0
!
interface Loopback7
ip address 172.16.7.2 255.255.255.0
!
interface Loopback8
ip address 172.16.8.2 255.255.255.0
!
interface Loopback9
ip address 172.16.9.2 255.255.255.0
!
interface Loopback10
ip address 172.16.10.2 255.255.255.0
!
interface Loopback11
ip address 172.16.11.2 255.255.255.0
!
interface Loopback12
ip address 172.16.12.2 255.255.255.0
!
interface Loopback13
no ip address
!
interface Loopback14
no ip address
!
interface Loopback15
no ip address
!
interface FastEthernet0/0
ip address 10.0.24.2 255.255.255.248
duplex auto
speed auto
!
interface Serial0/0
no ip address
no fair-queue
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
router eigrp 1
network 10.0.24.0 0.0.7.255
network 172.16.0.0
distribute-list prefix test out
no auto-summary
!
ip forward-protocol nd
!
!
ip http server
no ip http secure-server
!
!
ip prefix-list test seq 5 deny 172.16.1.0/24
!
!
!
!
control-plane
!
!
!
line con 0
line aux 0
line vty 0 4
password cisco
login
!
!
end
R2#

Prefix list in EIGRP redistribution

Zone:

Network Routers

Right now, R1 prefers R3 for everything. I would like to change this, so R1 prefers R2 for 172.16.1.1. But goes through R3 for everything else.   Can this be done with a prefix list on R2 only?

ie, config to add to R2:

ip prefix-list mylist seq 5 permit 172.16.1.1/32
access-list 1 permit any
!
route-map mymap permit 10
 match ip address prefix-list mylist
 set metric 100000 100 255 1 1500
!
route-map mymap permit 20
 match ip address 1
 set metric 10 100 255 1 1500
 



b
b